Discuss Scratch

Mr-Dave
Scratcher
100+ posts

Does the Micro:bit work for you under Scratch 3.0?

PinkyPepper wrote:



I made another video with Scratch 3.0 and the micro:bit. It's about a Space race game controlled by a DIY steering wheel with the micro:bit on it and a gas pedal and footbrake made out of wood. Maybe you like to see it: https://youtu.be/m_yalxqAwdw

Greetings from the Netherlands,

PinkyPepper

You did a great job on also making making this video. I think you should start a new topic with a name like “Success stories using Scratch 3.0 and the Micro:bit”.
Klaus24
New to Scratch
3 posts

Does the Micro:bit work for you under Scratch 3.0?

Working on a Mac.

I am able to use the microbit extension in SCRATCH 3.0 . The USB cable is connected ( has to be to put the scratch .hex file on it) and Bluetooth sees it and connects. I can write a program, run the program on the microbit. But.. there is no way to upload the program so that it will run on the micro bit when Bluetooth is turned off with only the battery pack powering the microbit.

I have used mblock 5 beta and am able to do it with that. Will there be some way to upload to the microbit in SCRATCH 3.0??

thanks..
Smurfs101
Scratcher
1 post

Does the Micro:bit work for you under Scratch 3.0?

The micro:bit has worked for me. Look at the next link and decide what two do. That is what I did, and it worked.
https://support.microbit.org/support/solutions/articles/19000026080-can-i-use-the-micro-bit-with-scratch-
16itople1
Scratcher
14 posts

Does the Micro:bit work for you under Scratch 3.0?

Mr-Dave wrote:

I've tried connecting my microbit to the Scratch 3 extension and have not had any luck. Scratch 3 seems to find my install of “Scratchlink” and my Windows 10 laptop connects via bluetooth to the microbit. The hex file transferred okay and the microbit spelled out it's name and showed a check mark (but I don't know what it is supposed to show). However, the Scratch extension pop-up just shows no devices found. Has anyone tried using it?

My browser / operating system: Windows NT 10.0, Chrome 67.0.3396.99, Flash 30.0 (release 0)


I had this problem but then it turned out to be a Bluetooth error so I restarted my PC. It now works perfectly! I'm not sure if this will work for you though. Honestly, I think it should auto connect when it's plugged in via usb to the computer.

Hope this helps,

Powered by DjangoBB

Standard | Mobile