Discuss Scratch

BFDISuperFan
Scratcher
100+ posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

I'm not sure if this counts as a bug, but the Looks sprite “ghost effect” no longer seems to have the cap that prevents it from going over 100 and under 0. Because of this, I have to manually set the ghost effect for a sprite to 100 to make sure that it doesn't stay invisible when I do
repeat (10)
change [ghost] effect by (-10)
What happened to the value caps for the effects? Have they not been implemented yet?
I hope this bug gets fixed soon, lots of sprites that use ghost effect no longer show when they should, and I don't want to have to put a block that fixes their value on every single one of them just to circumvent this. I believe that I shouldn't have to change my code just because of a new version of Scratch. If it could happen, Scratch 2.0 projects should function EXACTLY like they did there, in 3.0.

Last edited by BFDISuperFan (Jan. 4, 2019 01:12:38)


Oh hi signature reader! Thanks for reading this post. I’m BFDISuperFan, and I really love rhythm games. Oh, and while you’re here reading this, if you also like rhythm games, how about you go try out my attempt at porting DDRMAX2 on Scratch?
I'm also attempting to recreate beatmania IIDX 15: DJ TROOPERS on Scratch, but right now it's just a glorified animation gallery, check it out if you're interested!
What? An evil kumquat? Eating signatures!? Haha, you come up with some funny things-
Hey, where did my closing signature go?
mmnagelia
Scratcher
100+ posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

i just made added a new control and now the project just suddenly stops working

Learning Node.js? Great! But, don't waste your time creating a web server. I already created a fully functional Node.js server on Github right here! It also has a very detailed documentation!
Or are you interested in making games in Unity? Want to see how I'm making my very own FPS game? Then see my FPS-Game repo right here!
moviestudiosLA
Scratcher
1 post

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

Whenever I try to record a sound, the sound gets all glitchy and it sounds like I am talking over an old radio. This was working fine on my same computer before, and it just started doing this. I've tried it on another computer too and it is still doing it. I tried to clean out the mic too.
Windows 10 operating system
Dell computer?
say [???] for (2) secs
coolstorm
Scratcher
11 posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

For some reason, when I was making a game, my sprite didn't seem to detect the fact that my mouse was touching it when I dragged the character around. Is that just a glitch with my programming or is it some new bug in Scratch 3.0?

BFDISuperFan
Scratcher
100+ posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

For some reason, some scripts that ARE in the sprite and DO their respective functions randomly disappear, even though they're still there. In my DDRMAX2 project, two sprites named _cursor P1 and _cursor P2 have a certain script that I couldn't find. I looked through the entire script area, but still no luck. I was using Google Chrome on a Macbook Air running MacOS Mojave 10.14. Even when I dragged a script from one sprite to the other, I still couldn't see it. I had to reload my project just to see the TRANSFERRED script. Even then, I still couldn't find the original script.

Oh hi signature reader! Thanks for reading this post. I’m BFDISuperFan, and I really love rhythm games. Oh, and while you’re here reading this, if you also like rhythm games, how about you go try out my attempt at porting DDRMAX2 on Scratch?
I'm also attempting to recreate beatmania IIDX 15: DJ TROOPERS on Scratch, but right now it's just a glorified animation gallery, check it out if you're interested!
What? An evil kumquat? Eating signatures!? Haha, you come up with some funny things-
Hey, where did my closing signature go?
block866
Scratcher
37 posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

I can't load sb3 files, it just simply doesn't work.

who?
pondermake
Scratch Team
100+ posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

coolstorm wrote:

For some reason, when I was making a game, my sprite didn't seem to detect the fact that my mouse was touching it when I dragged the character around. Is that just a glitch with my programming or is it some new bug in Scratch 3.0?

I know that was common a bug in my code when I started making things with “touching mouse” sensing block. We haven't heard anything like that yet, but maybe check your code? If it persists you can let us know
pondermake
Scratch Team
100+ posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

BFDISuperFan wrote:

I'm not sure if this counts as a bug, but the Looks sprite “ghost effect” no longer seems to have the cap that prevents it from going over 100 and under 0. Because of this, I have to manually set the ghost effect for a sprite to 100 to make sure that it doesn't stay invisible when I do
repeat (10)
change [ghost] effect by (-10)
What happened to the value caps for the effects? Have they not been implemented yet?
I hope this bug gets fixed soon, lots of sprites that use ghost effect no longer show when they should, and I don't want to have to put a block that fixes their value on every single one of them just to circumvent this. I believe that I shouldn't have to change my code just because of a new version of Scratch. If it could happen, Scratch 2.0 projects should function EXACTLY like they did there, in 3.0.
Yes, this is a known bug as well! Thank you for bringing that up. We're with you on that, they should definitely function the same across versions. We're very close to getting a fix in for that, stay tuned.
pondermake
Scratch Team
100+ posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

BFDISuperFan wrote:

For some reason, some scripts that ARE in the sprite and DO their respective functions randomly disappear, even though they're still there. In my DDRMAX2 project, two sprites named _cursor P1 and _cursor P2 have a certain script that I couldn't find. I looked through the entire script area, but still no luck. I was using Google Chrome on a Macbook Air running MacOS Mojave 10.14. Even when I dragged a script from one sprite to the other, I still couldn't see it. I had to reload my project just to see the TRANSFERRED script. Even then, I still couldn't find the original script.

Ah, thanks for bringing that to our attention! So I just found that there are other posts reporting the same problem. I'll make note of it in this forum and pass it on to the team.
pondermake
Scratch Team
100+ posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

moviestudiosLA wrote:

Whenever I try to record a sound, the sound gets all glitchy and it sounds like I am talking over an old radio. This was working fine on my same computer before, and it just started doing this. I've tried it on another computer too and it is still doing it. I tried to clean out the mic too.
Windows 10 operating system
Dell computer?
say [???] for (2) secs
Thanks for reporting this! We've heard a few other issues with audio quality; hope to have a fix soon!
pondermake
Scratch Team
100+ posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

Blossom_Crowfeather wrote:

when i try to view projects, its just a white screen. im not able to view anything for some strange reason. its been like this for the past 2 hours or so. is there a way to fix this?
Oh no, is it still doing this for you? Or is it working now? It could have been due to servers being down. I am not sure what other issue this is related to you, but I can mention to our dev team. Thanks!
Islalily
Scratcher
37 posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

I know some scratchers who use safari, and they can't make or veiw projects, and also, sometimes it takes around 2 minutes to sign in, and it's the same for my brother. But otherwise I really like 3.0!!!!!
professorgaspar
New to Scratch
5 posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

pondermake wrote:

Blossom_Crowfeather wrote:

when i try to view projects, its just a white screen. im not able to view anything for some strange reason. its been like this for the past 2 hours or so. is there a way to fix this?
Oh no, is it still doing this for you? Or is it working now? It could have been due to servers being down. I am not sure what other issue this is related to you, but I can mention to our dev team. Thanks!

I tried google chrome in imacs with 10.6.8 and chrome 49. and didn´t work (fixed blue screen when loading), tried with ibook pro with chrome 71 and ok and for last tried chrome in a PC with chrome 71 and worked again. My problem it´s that i have classes to do in imacs, with 10.6.8 (no more update possible) and chrome 49, because i have more than 100 kids waiting to scratch a bit. Please get em a solution as soon as possible.
RainbowGeckos
Scratcher
40 posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

When I was choosing some animation examples to use for requesting a part in a MAP I was playing them and every one of them had lost it's timing and it couldn't display the whole animation and things didn't line up. I know the timing was perfect before, I don't know if this is a switching to 3.0 problem or if it's something else. Can this be fixed?

An example can be found here You can see the white coming in but stopped.
lgretton
New to Scratch
1 post

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

One big problem with the web-based Scratch 3 is there's no way to specify a save location when saving a project.

I just tried with the offline editor and it basically has the same problem: although I can specify a file name and location to save as, it won't remember that so the next time I save I have to hunt again.

It could really do with good old fashioned ‘Save’ and ‘Save As…’ options.

We run Scratch in a Code Club where the kids won't have Scratch accounts so we have to save projects locally (looks like local save is the only option anyway for the offline editor). The offline editor is generally preferable as there's less scope for losing an entire project if a browser tab is closed or the back button is pressed.
pondermake
Scratch Team
100+ posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

lgretton wrote:

One big problem with the web-based Scratch 3 is there's no way to specify a save location when saving a project.

I just tried with the offline editor and it basically has the same problem: although I can specify a file name and location to save as, it won't remember that so the next time I save I have to hunt again.

It could really do with good old fashioned ‘Save’ and ‘Save As…’ options.

We run Scratch in a Code Club where the kids won't have Scratch accounts so we have to save projects locally (looks like local save is the only option anyway for the offline editor). The offline editor is generally preferable as there's less scope for losing an entire project if a browser tab is closed or the back button is pressed.

Thanks for the feedback. Specifying save location in online editor is definitely something we would like to have, seeing that it would really make things easier. Not sure when we can add this in but I agree with you on this one! Will make note.
-KirbyGamer-
Scratcher
9 posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★


god286 wrote:

danceingg wrote:

RyGuy1107 wrote:

I can't load sprites from my backpack for some reason. Do you know why? Could it be because they are from an older version of Scratch(Scratch 2.0)?
no there are updates on the backpack
if you saw the project “moving your backpack to 3.0” then u would have known why
good luck trying to make the sprites over again!
I did, the error is when some scratchers try to add them back (including me) it will say “Error loading backpack.”

I had a project with my stuff (over 500 items, I don't need them) and when I added some new sounds to the backpack, it said “Loading” and then after “Error loading backpack” So even when I add new 3.0 stuff the backpack doesn't load. But most of the time it works…
-KirbyGamer-
Scratcher
9 posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

mmnagelia wrote:

i just made added a new control and now the project just suddenly stops working
That happened to me too, i saved and reloaded and it was ok
DarthDurinsBANEling
Scratcher
12 posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

Whenever I try to look at one of my projects or another person’s project it just shows a blank blue screen. Is it because I’m using an iPad? Before 3.0 I could view projects just fine on the iPad.
Aegisium_Z
Scratcher
89 posts

[thread closed] ★ Known Bugs & Glitches on 3.0 ★

i was scrolling through the comments in multiple projects(dont remember which projects) I see the same exact comment with the same exact replies twice

Powered by DjangoBB

Standard | Mobile