Discuss Scratch

1 post

CamJam Edukit 3 and Scratch 2 on Raspberry Pi 2 does not work.

Dear all,

Please could you lend me a hand ?

I tried to let pilot my CamJan Edukit 3 Robot with Scratch2 on my Raspberry PI for my 8 year old son, and I don't succeed.

I have thus a Raspeberry Pi 2 Model 8 V1.1
Running with the latest version of Raspbian Strech of 2017-11-29
Did a complete update following : https://www.raspberrypi.org/documentation/raspbian/updating.md

But when I tried to program my CamJam Edukit (http://camjam.me/?page_id=1035) with Scratch 2 , following :
https://www.raspberrypi.org/documentation/usage/scratch/gpio/README.md or http://camjam.me/?page_id=2082 or even by downloadnig projects as https://scratch.mit.edu/projects/106704810/ my motors don't start.

However, as proof that my CamJam Edukit 3 Motor pack is correctly fitted on my Raspberry PI, I installed : https://github.com/recantha/EduKit3-RC-Keyboard and this is correctly working.

Thus my conclusion is that the issue should be between Scratch2 and Raspberry PI, or between Scratch2 and the CamJam Edukit3 somewhere.

Also not clear, is if in Scratch2 I need to add the extension “Pi GPIO”. Although the above listed Scratch Programs, with or without this extension do not work while thus the python application https://github.com/recantha/EduKit3-RC-Keyboard is working.

I must have missed a link between Scratch2 and the EdukitMotorBoard Addon I think, but I don't succeed to get it working.

Already thaks for your help,

Best regards,

100+ posts

CamJam Edukit 3 and Scratch 2 on Raspberry Pi 2 does not work.

You should use Scratch (not Scratch 2) to control the CamJam EduKit3 Robot


Powered by DjangoBB

Standard | Mobile