Discuss Scratch

god286
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

Marc92020 wrote:

(with this part i cant run anymore commands)
That's intentional, press Ctrl + C (or something on Windows) to quit it, and stop the server.

Marc92020 wrote:

what happens when this happens:
You need to install python 2.7

Last edited by god286 (Jan. 2, 2022 03:11:53)



                 _ ____  ___   __   
__ _ ___ __| |___ \( _ ) / /_
/ _` |/ _ \ / _` | __) / _ \| '_ \
| (_| | (_) | (_| |/ __/ (_) | (_) |
\__, |\___/ \__,_|_____\___/ \___/
|___/
^ inspired by @Chiroyce, made with figlet


Marc92020
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

god286 wrote:

Marc92020 wrote:

(with this part i cant run anymore commands)
That's intentional, press Ctrl + C (or something on Windows) to quit it, and stop the server.
oh ok

god286 wrote:

Marc92020 wrote:

what happens when this happens:
You need to install python 2.7
the only version closest to python 2.7 that isnt in python 3x was python 2.5.4

Marc92020


Come to the Scratch Customs Shop!


when green flag clicked
add [Marc92020] to [List of Scratchers v]
repeat until <I leave Scratch :: operators>
show
think [Should I Scratch?]
set (answer) to [Yes]
broadcast [KEEP SCRATCHING!!! v]
end
stop [this signature v]
kccuber
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

Marc92020 wrote:

the only version closest to python 2.7 that isnt in python 3x was python 2.5.4
no, remove that one and get python 2.7.18 from the python website


Made using Nord Theme & Inkscape
Marc92020
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

kccuber wrote:

Marc92020 wrote:

the only version closest to python 2.7 that isnt in python 3x was python 2.5.4
no, remove that one and get python 2.7.18 from the python website
i got it

Marc92020


Come to the Scratch Customs Shop!


when green flag clicked
add [Marc92020] to [List of Scratchers v]
repeat until <I leave Scratch :: operators>
show
think [Should I Scratch?]
set (answer) to [Yes]
broadcast [KEEP SCRATCHING!!! v]
end
stop [this signature v]
SDFTDusername
Scratcher
30 posts

Guide to Modding Scratch 3.0

Marc92020 wrote:

what happens when this happens:
Python was not found; run without arguments to install from the Microsoft Store, or disable this shortcut from Settings > Manage App Execution Aliases.
npm ERR! code 9009
npm ERR! path C:\Users\-username-\scratch-blocks
npm ERR! command failed
npm ERR! command C:\Windows\system32\cmd.exe /d /s /c python build.py && webpack

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\-username-\AppData\Local\npm-cache\_logs\2022-01-02T02_14_10_189Z-debug.log]

also this happens too:
        [./node_modules/minilog/lib/common/filter.js] 1.36 KiB {main} [built]
[./node_modules/minilog/lib/common/minilog.js] 1.55 KiB {main} [built]
[./node_modules/minilog/lib/web/array.js] 319 bytes {main} [built]
[./node_modules/minilog/lib/web/console.js] 925 bytes {main} [built]
[./node_modules/minilog/lib/web/index.js] 1.28 KiB {main} [built]
[./node_modules/minilog/lib/web/jquery_simple.js] 2.16 KiB {main} [built]
[./node_modules/minilog/lib/web/localstorage.js] 530 bytes {main} [built]
[./node_modules/scratch-vm/src/dispatch/shared-dispatch.js] 14.7 KiB {main} [built]
[./node_modules/scratch-vm/src/dispatch/worker-dispatch.js] 7.62 KiB {main} [built]
[./node_modules/scratch-vm/src/extension-support/argument-type.js] 686 bytes {main} [built]
[./node_modules/scratch-vm/src/extension-support/block-type.js] 1.02 KiB {main} [built]
[./node_modules/scratch-vm/src/extension-support/target-type.js] 308 bytes {main} [built]
[./node_modules/scratch-vm/src/util/log.js] 84 bytes {main} [built]
[./node_modules/webpack/buildin/global.js] (webpack)/buildin/global.js 472 bytes {main} [built]
+ 5 hidden modules
i 「wdm」: Compiled successfully.
(with this part i cant run anymore commands)
first problem: if you're running in wsl then install python2 as python if windows then install python 2
second problem: you can press CTRL+Z or CTRL+C to continue doing commands

please help me make my mod! you will be credited!
samq64
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

I tried installing scratch-blocks with WSL and it still didn't work.
SUCCESS: blockly_uncompressed_horizontal.js
SUCCESS: blockly_uncompressed_vertical.js
FATAL ERROR
Required namespace "goog.events.EventWrapper" never defined.
??? at line 57:
goog.requireType('goog.events.EventWrapper');
^
I successfully built scratch-blocks with WSL after adding
goog.require('goog.debug.ErrorHandler');
goog.require('goog.events.EventLike');
goog.require('goog.events.EventWrapper');
to /core/blockly.js.

Last edited by samq64 (Jan. 8, 2022 22:55:11)

kccuber
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

samq64 wrote:

I tried installing scratch-blocks with WSL and it still didn't work.
SUCCESS: blockly_uncompressed_horizontal.js
SUCCESS: blockly_uncompressed_vertical.js
FATAL ERROR
Required namespace "goog.events.EventWrapper" never defined.
??? at line 57:
goog.requireType('goog.events.EventWrapper');
^
I successfully built scratch-blocks with WSL after adding
goog.require('goog.debug.ErrorHandler');
goog.require('goog.events.EventLike');
goog.require('goog.events.EventWrapper');
to /core/blockly.js.
I had the EXACT SAME ERROR. Delete scratch-blocks and reclone from https://github.com/LLK/scratch-blocks.git (Keep the .git at the end)


Made using Nord Theme & Inkscape
samq64
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

kccuber wrote:

I had the EXACT SAME ERROR. Delete scratch-blocks and reclone from https://github.com/LLK/scratch-blocks.git (Keep the .git at the end)
Now it's broken again…
kccuber
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

samq64 wrote:

kccuber wrote:

I had the EXACT SAME ERROR. Delete scratch-blocks and reclone from https://github.com/LLK/scratch-blocks.git (Keep the .git at the end)
Now it's broken again…
whut
ok did you remember to npm/yarn link


Made using Nord Theme & Inkscape
samq64
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

kccuber wrote:

samq64 wrote:

kccuber wrote:

I had the EXACT SAME ERROR. Delete scratch-blocks and reclone from https://github.com/LLK/scratch-blocks.git (Keep the .git at the end)
Now it's broken again…
whut
ok did you remember to npm/yarn link
What I meant was that npm install was successful after I modified blockly.js, but the editor was crashing, so I cloned scratch-blocks again with .git at the end (I'm cloning TurboWarp's repos, not LLK's) and got the same error I posted above. After re-adding the blockly.js changes and running npm start, the code editor crashes with the same error I got yesterday, which is
lazy scratch-blocks: TypeError: goog.isString is not a function

Edit: I fixed that one, but now I'm getting another similar error:
lazy scratch-blocks: TypeError: goog.isFunction is not a function

Last edited by samq64 (Jan. 10, 2022 17:36:08)

samq64
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

The errors never end!
Oops! Something went wrong.

We are so sorry, but it looks like TurboWarp has crashed. Please refresh your page to try again.

lazy scratch-blocks: Error: Field "function(a,b){this.size_=new goog.math.Size(0,0);this.class_=b;this.setValue(a)}" must have a fromJson function
HelloLanguage
New to Scratch
18 posts

Guide to Modding Scratch 3.0

It is not working.

Nah! wrote:

Vomit.
-ElectronicArts-
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

HelloLanguage wrote:

It is not working.
what

AT is cool
kccuber
Scratcher
1000+ posts

Guide to Modding Scratch 3.0

samq64 wrote:

The errors never end!
Oops! Something went wrong.

We are so sorry, but it looks like TurboWarp has crashed. Please refresh your page to try again.

lazy scratch-blocks: Error: Field "function(a,b){this.size_=new goog.math.Size(0,0);this.class_=b;this.setValue(a)}" must have a fromJson function
Uhh…. Delete the whole thing, try again, using these links for git cloning:
git clone --depth=1 https://github.com/TurboWarp/scratch-gui.git
git clone https://github.com/TurboWarp/scratch-blocks.git
git clone https://github.com/TurboWarp/scratch-vm.git

Last edited by kccuber (Jan. 11, 2022 22:11:37)



Made using Nord Theme & Inkscape
justamirror
Scratcher
4 posts

Guide to Modding Scratch 3.0

Guess what guys! I got a version of scratch running with this tutorial: https://medium.com/@hiroyuki.osaki/how-to-develop-your-own-block-for-scratch-3-0-1b5892026421
Windows Linux subsystem is amazing (though you will have to install yarn for windows linux subsystem: see here: https://yarnpkg.com/getting-started/install)

My name says it all. I'm just a mirror, that's it lol.

Powered by DjangoBB

Standard | Mobile