Discuss Scratch

my7h
New to Scratch
2 posts

How do I get Scratch Offiline Editor to work on Ubuntu 16.04 64-bit

I need to use Scratch for a computer club I am in from school. I use Ubuntu but there are problems maybe cause I use 64 bit. Here's what I am getting: “/tmp/air.plkeMg/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory” This is when I try and do “./AdobeAIRInstaller.bin”. Any help? Trying to install libgtk-x11-2.0.so.0 gives me this:
“Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libgtk-x11-2.0.so.0
E: Couldn't find any package by glob ‘libgtk-x11-2.0.so.0’
E: Couldn't find any package by regex ‘libgtk-x11-2.0.so.0’”

Any help?
myeducate
Scratcher
500+ posts

How do I get Scratch Offiline Editor to work on Ubuntu 16.04 64-bit

my7h wrote:

I need to use Scratch for a computer club I am in from school. I use Ubuntu but there are problems maybe cause I use 64 bit. Here's what I am getting: “/tmp/air.plkeMg/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory” This is when I try and do “./AdobeAIRInstaller.bin”. Any help? Trying to install libgtk-x11-2.0.so.0 gives me this:
“Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libgtk-x11-2.0.so.0
E: Couldn't find any package by glob ‘libgtk-x11-2.0.so.0’
E: Couldn't find any package by regex ‘libgtk-x11-2.0.so.0’”

Any help?
Here's what you're missing(run in Terminal)
sudo apt-get install libgtk*
sudo apt-get update
Then try. Any problems, just tell me. Also, I suggest you upgrade to Ubuntu 17.x


my7h
New to Scratch
2 posts

How do I get Scratch Offiline Editor to work on Ubuntu 16.04 64-bit

myeducate wrote:

my7h wrote:

I need to use Scratch for a computer club I am in from school. I use Ubuntu but there are problems maybe cause I use 64 bit. Here's what I am getting: “/tmp/air.plkeMg/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory” This is when I try and do “./AdobeAIRInstaller.bin”. Any help? Trying to install libgtk-x11-2.0.so.0 gives me this:
“Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libgtk-x11-2.0.so.0
E: Couldn't find any package by glob ‘libgtk-x11-2.0.so.0’
E: Couldn't find any package by regex ‘libgtk-x11-2.0.so.0’”

Any help?
Here's what you're missing(run in Terminal)
sudo apt-get install libgtk*
sudo apt-get update
Then try. Any problems, just tell me. Also, I suggest you upgrade to Ubuntu 17.x
I'm getting “/tmp/air.uSRiIA/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory” after doing those commands and updating, after doing “./AdobeAIRInstaller.bin”.
myeducate
Scratcher
500+ posts

How do I get Scratch Offiline Editor to work on Ubuntu 16.04 64-bit

my7h wrote:

myeducate wrote:

my7h wrote:

I need to use Scratch for a computer club I am in from school. I use Ubuntu but there are problems maybe cause I use 64 bit. Here's what I am getting: “/tmp/air.plkeMg/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory” This is when I try and do “./AdobeAIRInstaller.bin”. Any help? Trying to install libgtk-x11-2.0.so.0 gives me this:
“Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package libgtk-x11-2.0.so.0
E: Couldn't find any package by glob ‘libgtk-x11-2.0.so.0’
E: Couldn't find any package by regex ‘libgtk-x11-2.0.so.0’”

Any help?
Here's what you're missing(run in Terminal)
sudo apt-get install libgtk*
sudo apt-get update
Then try. Any problems, just tell me. Also, I suggest you upgrade to Ubuntu 17.x
I'm getting “/tmp/air.uSRiIA/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory” after doing those commands and updating, after doing “./AdobeAIRInstaller.bin”.
./AdobeAIRInstaller.bin means “AdobeAIRInstaller.bin” in the current directory. Have you made sure that terminal is in the same directory the AdobeAirInstaller is? If not, just cd to it.


Powered by DjangoBB

Standard | Mobile