Discuss Scratch

theonlygusti
Scratcher
1000+ posts

Migrating to LEDE router from TISCALI one

I finally managed to get LEDE running on my BT Home Hub 3A but can't connect it to the internet.

I am moving from a Utility Warehouse-issued router (Technicolor TG589vac) and novice27b's signature tells me that my ISP is TISCALI.

Here's the /etc/config/network of my last router:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option default_ps '0'

config interface 'lan'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option force_link '0'
option igmp_snooping '1'
option ipv6 '0'
option ip6assign '64'
list ifname 'vlan_eth0'
list ifname 'vlan_eth1'
list ifname 'vlan_eth2'
list ifname 'vlan_eth3'
option ipaddr '192.168.1.2'

config device 'eth0'
option mtu '1500'
option name 'eth0'

config device 'eth1'
option mtu '1500'
option name 'eth1'

config device 'eth2'
option mtu '1500'
option name 'eth2'

config device 'eth3'
option mtu '1500'
option name 'eth3'

config device 'vlan_eth0'
option type '8021q'
option ifname 'eth0'
option name 'vlan_eth0'
option mtu '1500'
option vid '1'

config device 'vlan_eth1'
option type '8021q'
option ifname 'eth1'
option name 'vlan_eth1'
option mtu '1500'
option vid '1'

config device 'vlan_eth2'
option type '8021q'
option ifname 'eth2'
option name 'vlan_eth2'
option mtu '1500'
option vid '1'

config device 'vlan_eth3'
option type '8021q'
option ifname 'eth3'
option name 'vlan_eth3'
option mtu '1500'
option vid '1'

config switch 'bcmsw'
option reset '1'
option type 'bcmsw'
option qosimppauseenable '0'
option unit '1'
option enable_vlan '1'
option jumbo '1'

config switch_vlan 'lan_switch'
option device 'bcmsw'
option vlan '1'
option ports '1* 2* 3* 4* 8t'

config interface 'wan'
option reqopts '1 3 6 15 33 42 51 121 249'
option vendorid 'Technicolor'
option graceful_restart '1'
option authfail '0'
option mtu '1500'
option ipv6 '0'
option ifname 'atm0'
option vci '38'
option username '01808722737@uwclub.net'
option password
option proto 'pppoa'
option keepalive '5,10'
option vpi '0'
option auto '1'

config interface 'bt_iptv'
option ifname 'wan_vlan'
option proto 'static'
option ipaddr '169.254.10.1'
option netmask '255.255.255.255'
option auto '0'

config device 'eth4'
option mtu '1500'
option name 'eth4'

config device 'ptm0'
option mtu '1508'
option name 'ptm0'

config device 'vlan_wan'
option type '8021q'
option ifname 'ptm0'
option mtu '1508'
option name 'wan_vlan'
option vid '101'

config interface 'wwan'
option auto '0'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'
option reqopts '12 21 22 23 24 25 31 56 64 67 82 83'
option noslaaconly '1'

config config 'config'
option wan_mode 'pppoa'

and here's the one I'm using for my “new” router (the one running LEDE that I'd like to connect to internet):

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd8b:85df:b50b::/48'

config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'

config dsl 'dsl'
option annex 'a'
option firmware '/lib/firmware/adsl.bin'

config adsl-device 'adsl'
option fwannex 'a'
option annex 'a'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device 'lan_dev'
option name 'eth0'
option macaddr '00:e0:92:00:01:40'

config interface 'wan'
option reqopts '1 3 6 15 33 42 51 121 249'
option vendorid 'Technicolor'
option mtu '1500'
option _orig_ifname 'nas0'
option _orig_bridge 'false'
option graceful_restart '1'
option authfail '0'
option ifname 'atm0'
option proto 'pppoa'
option atmdev '0'
option vci '38'
option vpi '0'
option username '01808722737@uwclub.net'
option ipv6 'auto'
option encaps 'llc'
option keepalive '5 10'

config device 'wan_dev'
option name 'nas0'
option macaddr '00:e0:92:00:01:41'

config interface 'wan6'
option ifname 'pppoe-wan'
option proto 'dhcpv6'

Last edited by theonlygusti (July 1, 2017 13:30:42)


novice27b
Scratcher
1000+ posts

Migrating to LEDE router from TISCALI one

Just a heads up, the email address listed in those configs is presumably also your home phone number, which you might not have intended to share.

i use arch btw

Powered by DjangoBB

Standard | Mobile