Discuss Scratch

TDR-Games
Scratcher
100+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Nice work! This will make my life a lot easier…















–Banners Above
–move selected to top

Xanderbee337
Scratcher
64 posts

Whiskers: Scratch 2.0 for Incompatible Devices

so this is scratch 1.4 + scratch 2.0?
Penguin5664
Scratcher
100+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Xanderbee337 wrote:

so this is scratch 1.4 + scratch 2.0?
Yes, just what you meant.

Whiskers is a Scratch 2.0 for incompatible devices.
However, the owner of this app is working on a recent, and yet new version that will allow users use Vector Mode in a Squeak VM!




Yeah, it uses a Squeak VM. Amazing isn't it?

((づ。◕‿‿◕。::sensing)づ::sensing) // This is "Mini-Bloky". He protects my signature from the kumquats!
How many Block Requests we can get? Please request! Check @78ch3's Everything Shop, too!
when gf clicked :: #B46200
vector :: #C56B00
scratch :: #DA8B00
blocks! :: control
pawellabaj
Scratcher
1 post

Whiskers: Scratch 2.0 for Incompatible Devices

Hi,

I would like to run Whiskers on Raspberry. I have installed it according to article at Simplesi.

When I try to load project created in Scratch and ScratchGPIO 8, Whiskers crashes without error dialog. I am using Raspberry Pi 3 with Raspbian.

Could you help me to check and solve it?
Where can I find any log file? What should I provide you to have more information?

Regards
Penguin5664
Scratcher
100+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

I found more bugs for you to fix

  • In the “Block Tips” bar, when you click the Operators category, the Motion blocks show up.
  • The (current [minute v]) block reports as "Sprite_Name current %z [ ]" and, yes, the value in the reporter is empty. It only works “click-reporting”
  • The (days since 2000) is wrong D: by I think, ummm… 13 more to clone it maybe?
  • I dont think you need the (username) reporter block, because it reports it empty, and wont even let you play if it uses login detector.
  • As mentioned before, the blocks stacked in a custom block, after the custom block getting edited, get deleted, it drives me crazy D:.


And some other things you may want to change:

  • Wrong color palette (Control Category (Not necessarily needed to be changed (Lighter color than it should be)))
  • The block anti-aliasing looks good, but a problem is that the shades are almost like the normal block colors.
  • Wrong color palette (Events (Turn to brown color))
  • You must want to change the custom block category color?
  • 99.9% not necessary, but the “red” hat blocks have lighter red tops.


Also it has been past 2 weeks and no SVG support yet is there a beta for the SVG editor for Squeak and SVG block rendering?



Thanks for reading this. Sincerely,
~Penguin5664

((づ。◕‿‿◕。::sensing)づ::sensing) // This is "Mini-Bloky". He protects my signature from the kumquats!
How many Block Requests we can get? Please request! Check @78ch3's Everything Shop, too!
when gf clicked :: #B46200
vector :: #C56B00
scratch :: #DA8B00
blocks! :: control
-Anvard-
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Bump?

Those who strive above all else to be rich in worldly goods are often trying to hide their spiritual poverty.
-Anonymous
Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither.
-Benjamin Franklin
There is no greater love than that, that a man should lay down his life for his friend. Think, Daniel, can you repay such love with hate?
-The Bronze Bow, by Elizabeth George Speare
All endings are also beginnings. We just don't know it at the time.
-March Albom
KScratchBigfan
Scratcher
3 posts

Whiskers: Scratch 2.0 for Incompatible Devices

NoMod-Programming wrote:

Hi everyone! I'm NoMod-Programming, the developer of Whiskers. Whiskers is a scratch modification that plans to be a full rewrite of the current 2.0 version in Squeak, the software Scratch 1.x was made in. This way, OSes that don't support Flash, like the one the Raspberry Pi uses, can use the 2.0 version.


Information and Installation instructions are available at: whiskers.gwiddle.co.uk.
To give suggestions, report a bug, or anything else, please visit the whiskers forums (http://whiskers.gwiddle.co.uk/discuss/)

The latest version is v24.1

NoMod-Programming wrote:

First screenshot:

If you want the raw image so you can zoom in, it is here: http://i.cubeupload.com/9tZn35.png
NOTE: the blocks from 2.0 (and 2.0 beta blocks) are red to help the user distinguish them from the others

NoMod-Programming wrote:

Hi everyone! I'm NoMod-Programming, the developer of Whiskers. Whiskers is a scratch modification that plans to be a full rewrite of the current 2.0 version in Squeak, the software Scratch 1.x was made in. This way, OSes that don't support Flash, like the one the Raspberry Pi uses, can use the 2.0 version.


Information and Installation instructions are available at: whiskers.gwiddle.co.uk.
To give suggestions, report a bug, or anything else, please visit the whiskers forums (http://whiskers.gwiddle.co.uk/discuss/)

The latest version is v24.1
The domain won't work. The whiskers.gwiddle.co.uk domain doesn't work and the discussion forums are showing 404.

Last edited by KScratchBigfan (June 9, 2017 06:51:16)

Penguin5664
Scratcher
100+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

KScratchBigfan wrote:

The domain won't work. The whiskers.gwiddle.co.uk domain doesn't work and the discussion forums are showing 404.

Then clicky!

((づ。◕‿‿◕。::sensing)づ::sensing) // This is "Mini-Bloky". He protects my signature from the kumquats!
How many Block Requests we can get? Please request! Check @78ch3's Everything Shop, too!
when gf clicked :: #B46200
vector :: #C56B00
scratch :: #DA8B00
blocks! :: control
jandrewg
Scratcher
100+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Jonathan50
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Couldn't they have used stand-alone flash player or implement PPAPI, or does Scratch expect to be in an HTML document? Having a whole web rendering engine will take up lots more memory and startup time

Last edited by Jonathan50 (June 23, 2017 22:15:04)

NickyNouse
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Yeah it sounds like they already had Flash set up on the OS, so Electron seems super unnecessary here? They probs could've ported it from the regular offline player and avoided packaging it with a copy of chromium

oh well, still good for them that they got it working I guess
infinitytec
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

NickyNouse wrote:

Yeah it sounds like they already had Flash set up on the OS, so Electron seems super unnecessary here? They probs could've ported it from the regular offline player and avoided packaging it with a copy of chromium

oh well, still good for them that they got it working I guess
Yeah.
Still no support for the Pi 1 and Zero.

They also have a GPIO extension built-in. That probably explains why they are using ScratchX.

Last edited by infinitytec (June 24, 2017 04:25:04)



Not here much, but sometimes I lurk.
God has a plan. He has a plan for everything, and everyone.
Blaze349
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Does S 3.0 make this obsolete?
Jonathan50
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Blaze349 wrote:

Does S 3.0 make this obsolete?
Not on devices where you can't get a fully Scratch-3.0 compatible browser.
NoMod-Programming
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Jonathan50 wrote:

Blaze349 wrote:

Does S 3.0 make this obsolete?
Not on devices where you can't get a fully Scratch-3.0 compatible browser.
Just asking, what are some non-scratch-3 compatible browsers?

Long-since moved on from Scratch, if you need to find all my posts, search this in google: 3499447a51c01fc4dc1e8c3b8182b41cb0e88c67
Blaze349
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

NoMod-Programming wrote:

Jonathan50 wrote:

Blaze349 wrote:

Does S 3.0 make this obsolete?
Not on devices where you can't get a fully Scratch-3.0 compatible browser.
Just asking, what are some non-scratch-3 compatible browsers?
Firefox with NoScript.
Jonathan50
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

NoMod-Programming wrote:

Just asking, what are some non-scratch-3 compatible browsers?
Browsers that don't support modern HTML5 and JavaScript (You might need to use one if you're using Windows 2000, but for Mac OS X 10.4 you can use TenFourFox.), or you might just prefer to use Whiskers because modern browsers run slow on your computer.

Blaze349 wrote:

Firefox with NoScript.
You could just disable NoScript

Last edited by Jonathan50 (July 15, 2017 02:38:57)

Jonathan50
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

The Whiskers site is down
infinitytec
Scratcher
1000+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

Jonathan50 wrote:

The Whiskers site is down
It's been down for a while. If you are trying to download it, I have a link in an earlier post.


Not here much, but sometimes I lurk.
God has a plan. He has a plan for everything, and everyone.
kenny2scratch
Scratcher
500+ posts

Whiskers: Scratch 2.0 for Incompatible Devices

NoMod-Programming wrote:

Jonathan50 wrote:

Blaze349 wrote:

Does S 3.0 make this obsolete?
Not on devices where you can't get a fully Scratch-3.0 compatible browser.
Just asking, what are some non-scratch-3 compatible browsers?
Many versions of IE
Also, any browser with JavaScript disabled.

The main reason I think Whiskers will still be cool is I can't really see how there will be a 3.0 offline editor.
Keep going!

post brought to you by the preview links bug and the uploads site bug. 看一下中文 Scratch 維基想參加?請參考這頁
Join the Scratch Wiki!
Made by Scratchers, for Scratchers, since December 6, 2008

Powered by DjangoBB

Standard | Mobile