dietbacon

Hi all!

Is one or more of your projects not loading, returning an error, or just seems to behave a lot differently than it did in Scratch 2.0? If so, please respond to this post with the following template filled out with as much detail as possible:

Project URL(s):

Error message displayed (if any):

Browser version & Operating System this happens in:

What browser extensions do you have installed (if any)?:

Description / other details of the behavior you see:


Note: This is not meant to collect reports about projects failing to load due to server issues, as these are temporary issues which are typically caused by heavy use of Scratch.


Projects which were previously failing to load with an error of “Oops, something went wrong!” followed by a very long error id are in the process of being fixed. Many of these projects are already working, and those that aren't should be within the next few days. This was being caused by sounds or images which failed to properly save to our servers before the editor was closed. We have fixed projects in this state by replacing the missing images or sounds with a “?” image so the projects can load. The problem which was causing projects to get saved in this state has been fixed. We’re sorry for the loss of images and sounds that come with this, in nearly all cases it is a single image or sound within the project that has been replaced.

E-D2345

Hello!
So for some reason after 3.0, my project “Jumplo-A Platformer” Link if you want to see for yourself: https://scratch.mit.edu/projects/247287017/
is having some issues. I would have a color detection for when the “lava” would turn a specific color, but for some reason, it won't detect it!
This issue I've been having with the color block has never happened before and I still don't know why it happens. Nothing's wrong with the code, it's just the block!

Not only this, but the ghost block doesn't work on some sprites. Not all sprites, just some. This I cannot explain, it's just happening for some odd reason.

Finally, my game when transferred from 2.0 to 3.0 made it look, “un-polished”. The best way I can describe it is that sometimes the sprites look foggy or one pixel seems bigger then the other. That's the best way I can describe it.

Overall, I don't know why this happens, but it just does. If you see this, could you please give it a look to see why this happens? I know I'm not the only one with this problem.

Thank you and have a good day!

mobluse

Project URL(s):
https://scratch.mit.edu/projects/137676871/
Starting FORTH Calculator Screen Keyboard
Last changed: 22 Dec 2016

Error message displayed (if any):
Not error messages from Scratch, but from the program itself. Gives error messages in Scratch3, but not in Scratch2.

Browser version & Operating System this happens in:
My browser / operating system: Linux, Chrome 65.0.3325.181, Flash 32.0 (release 0)
Chromium Version 65.0.3325.181 (Official Build) Built on Raspbian , running on Raspbian 9.6 (32-bit).
It's the most updated Raspbian running on a Raspberry Pi 3 B.

My browser / operating system: ChromeOS 11151.113.0, Chrome 71.0.3578.127, No Flash version detected
It's most updated HP Chromebook 11 G5 EE.

My browser / operating system: Windows NT 10.0, Chrome 73.0.3683.86, No Flash version detected

My browser / operating system: Windows NT 10.0, Firefox 66.0, Flash 27.0 (release 0)

What browser extensions do you have installed (if any)?:
uBlock Origin (Chrome)
Adblock Plus (Firefox)

Description / other details of the behavior you see:
It should start as in this video from Scratch2:
https://youtu.be/FwEgRetggFg
In Scratch 3 it doesn't compile the code, but instead shows its own error messages about undefined words. It's the colon definitions that don't work.

It still works on https://phosphorus.github.io/#137676871 .

(If I save to my computer from online Scratch 3 and convert it from sb3 to sb2 it doesn't work in the Scratch 2 Offline Editor (same error as in Scratch 3), but I've found out that if I add another INIT under when GreenFlag clicked it works in the Scratch 2 Offline Editor. Even if I have two or three INITs in Scratch 3, it doesn't work there. Summary: It doesn't work in Scratch 3 even if I modify it and Scratch 3 trashes the project somewhat, but I can fix it using INIT twice so that I can run it in the Scratch 2 Offline Editor after converting it from sb3 to sb2 using a utility.

Edit 6th of May 2019: You no longer have to duplicate the INIT block in the Scratch 2 Offline Editor since the downloading of sb3-projects have been fixed, see https://scratch.mit.edu/discuss/topic/329513/?page=20#post-3474748.)

See inside shows no blocks for all sprites. This has been fixed, but the showstopper bug above is still there.

The reason for this bug has now been found: It's due to a bug in Scratch 3 regarding “broadcast and wait”, see https://scratch.mit.edu/discuss/topic/347098/

I have worked around it using a workaround by @TheLogFather and a version that works in Scratch 3 is here: https://scratch.mit.edu/projects/302444111/

mobluse

Project URL(s):
https://scratch.mit.edu/projects/13703270/
Double Rainbow in Minecraft Pi from Scratch RasPi
Last changed: 29 Oct 2013

https://scratch.mit.edu/projects/13537468/
Pixelated Double Rainbow (much faster than the above, but has the same glitch)
Last changed: 23 Oct 2013

https://scratch.mit.edu/projects/172284158/
Wormy Snake 4 AstroPi SenseHAT RaspberryPi (same glith, but even more obvious)
Last changed: 26 Aug 2017

Browser version & Operating System this happens in:
My browser / operating system: Linux, Chrome 65.0.3325.181, Flash 32.0 (release 0)
Chromium Version 65.0.3325.181 (Official Build) Built on Raspbian , running on Raspbian 9.6 (32-bit).
It's the most updated Raspbian running on a Raspberry Pi 3 B.

What browser extensions do you have installed (if any)?:
uBlock Origin

Description / other details of the behavior you see:
The large pen now makes square dots instead of circular disks as before. I think this change in Scratch3 breaks many old Scratch projects that e.g. used huge pen to color fill. This (the first) is a Scratch 1.4 project, but now there seems to be no way to download it as a Scratch 1.4 project, which is what you need for Scratch (NuScratch) in Raspberry Pi or other Scratch 1.4, since this project also can connect to Minecraft Pi.

The second project is Scratch 2. This glitch is not limited to Scratch 1.4 projects.

This glitch has now been fixed.

mobluse

Project URL(s):
https://scratch.mit.edu/projects/87860395/
Sewing machine/Symaskin
Last changed: 15 Nov 2015

Error message displayed (if any):
None. But the computer activity monitor stops and all memory is used. You can't use the mouse or keyboard.

Browser version & Operating System this happens in:
My browser / operating system: Linux, Chrome 65.0.3325.181, Flash 32.0 (release 0)
Chromium Version 65.0.3325.181 (Official Build) Built on Raspbian , running on Raspbian 9.6 (32-bit).
It's the most updated Raspbian running on a Raspberry Pi 3 B.

What browser extensions do you have installed (if any)?: uBlock Origin

Description / other details of the behavior you see:
Hangs (i.e. freezes) the computer; probably due to too many pictures, but I think Scratch3 should give some error message and stop. Now the only option is to pull the plug since you can't use the mouse or the keyboard.

Edit: It's possible to work around this glitch by increasing the swap size in Raspbian Stretch to 1024 MB (default is 100 MB), but I still think Scratch 3 should not hang the computer even if one hasn't increased the swap size.

D-ScratchNinja

So, a project I made called “Launch It!”…
View here: https://scratch.mit.edu/projects/276669220/
…has 15 views. I don't know if it has 15 views, though. Unless it was just a coincidence, I was logging out and logging in, viewing it as a guest, and logged in to my account a few times, and I saw the view count changing. It happened on January 2nd, very close to the time the server was put in maintenance mode again. Soon, I had problems viewing it while I was checking it out. I don't exactly know what was going on, but I'm pretty sure it had to do with Scratch 3 just launching on the site, and about to be put in maintenance mode again. If anyone can fix this, unless it was a coincidence, I'd like to know more about these view count issues if it's a thing, and fix it on the project if possible. Although, I don't know. It had 11 views yesterday, and today (January 3) it's 15. I could be wrong with the issue theory, but I just decided I'd throw it out there.

mobluse

Project URL(s):
https://scratch.mit.edu/projects/12957158/
Safety Net RasPi
Last changed: 4 Oct 2013

https://scratch.mit.edu/projects/59328372/
Lindenmayer L-systems RasPi
Last changed: 28 Apr 2015

https://scratch.mit.edu/projects/13197934/
PocketCalc – Pocket Calculator RasPi
Last changed: 13 Oct 2013

Browser version & Operating System this happens in:
My browser / operating system: Linux, Chrome 65.0.3325.181, Flash 32.0 (release 0)
Chromium Version 65.0.3325.181 (Official Build) Built on Raspbian , running on Raspbian 9.6 (32-bit).
It's the most updated Raspbian running on a Raspberry Pi 3 B.

What browser extensions do you have installed (if any)?: uBlock Origin

Description / other details of the behavior you see:
The variable watcher has disappeared in the first project. It is in this thumbnail in the top left corner and was there in Scratch 2:

This is a Scratch 1.4 project.

The variable watchers are also gone in the second project. This is also a Scratch 1.4 project as is the third. This glitch seems to be limited to Scratch 1.4 projects.

Scratch-Minion

Some costumes/sprites display correctly but a significant proportion don't.
Affects nearly all projects but only if running under Windows 10 Edge browser. (doesn't affect pen projects)

Project URL(s):
A simple example project URL: https://scratch.mit.edu/projects/276681204/ * but happens in nearly all projects! *

Browser version & Operating System this happens in:
Windows 10, only with the Edge browser! (not with Firefox or Chrome).

Description:
The Windows 10 Edge browser often does not display costumes correctly.
Some costumes/sprites display correctly but a significant proportion don't.
* If you “see inside” many many projects using the Windows 10 Edge browser, you see the complete costumes in the costume editor, but they do not appear in the editor “run” window, nor do they appear when the project is run in the usual Scratch environment.

Solution: Run and view Scratch projects using a different browser! Do not use the Windows 10 Edge browser!

* Note to Scratch Team: I think you should highlight this issue and tell Scratchers not to use the Edge browser for now, (or fix the Scratch/Edge browser compatibility problem). Otherwise Scratchers who use the Edge browser will see that most projects no longer work and may leave Scratch when it is just a browser compatibility problem.

* This is an issue with most of my converted Scratch 2.0 projects. My Scratching Post newspapers, The Scratch Movie, Scratch Blocks Comics etc all do not run properly under the Windows 10 Edge browser as sprites/costumes do not appear on the screen.

** The error does NOT occur under Chrome or Firefox.
I haven't checked other browsers.

Example project with the error: https://scratch.mit.edu/projects/276681204/
Note that you will only see this error if you are using the Windows 10 Edge browser.

The best solution was to run and view Scratch projects using a different browser!
A second less complete solution still under the Windows 10 Edge browser is to run projects in full screen mode. The costumes all then appear although I have found that mouse clicks on some areas of the costumes are not detected. Also you can't edit projects in fullscreen mode.

wheelsonfire

First of all @E-D2345, your game is AWESOME

I made it to the level with both the turret and laser, and I feel like I can beat it…

Will you say more about what's not working? I didn't totally understand. Not having worked on the project myself, all I see is everything seeming to work – I don't know the differences you're looking for.

I know what you mean about some 2.0 to 3.0 graphics not totally looking the same. There are aspects of that that we're working on, but some amount of detail on the pixel-by-pixel level might still be different.

mobluse

Project URL(s):
https://scratch.mit.edu/projects/135346157/
Sieve of Eratosthenes såll
Last changed: today

Browser version & Operating System this happens in:
My browser / operating system: Linux, Chrome 65.0.3325.181, Flash 32.0 (release 0)
Chromium Version 65.0.3325.181 (Official Build) Built on Raspbian , running on Raspbian 9.6 (32-bit).
It's the most updated Raspbian running on a Raspberry Pi 3 B.

What browser extensions do you have installed (if any)?: uBlock Origin

Description / other details of the behavior you see:
The list is above the ask dialog box. I think a new ask dialog should be on top of everything. This is fixed now.

It runs much slower in Scratch 3 on a faster computer (Raspberry Pi 3 B) than I used before (Raspberry Pi 2):
1431.6 s vs 591.9 s (both using turbo mode).

I only scrolled the text for Notes and yet it counts as updated today. Last actual update was over two years ago. This is fixed now.

lisa_wolfgang

https://scratch.mit.edu/projects/275999360/editor/
No error message.
My browser / operating system: Windows NT 10.0, Firefox 64.0, Flash 32.0 (release 0)
No browser extensions.

Mario can't jump as high as he used to because of the rounding of x and y position, a new “feature” of 3.0.

mobluse

Project URL(s):
https://scratch.mit.edu/projects/13210102/
ICAO/NATO Spelling Alphabet Trainer RasPi
Last changed: 14 Oct 2013

Browser version & Operating System this happens in:
My browser / operating system: Linux, Chrome 65.0.3325.181, Flash 32.0 (release 0)
Chromium Version 65.0.3325.181 (Official Build) Built on Raspbian , running on Raspbian 9.6 (32-bit).
It's the most updated Raspbian running on a Raspberry Pi 3 B.

What browser extensions do you have installed (if any)?: uBlock Origin

Description / other details of the behavior you see:
The sprites are mirrored - they should not be this. This is a Scratch 1.4 project.

sippingcider

Project URL(s): https://scratch.mit.edu/projects/237787163/

Error message displayed (if any): none

Browser version & Operating System this happens in:
My browser / operating system: Windows NT 10.0, Chrome 71.0.3578.98, No Flash version detected

What browser extensions do you have installed (if any)?: adblock

Description / other details of the behavior you see:
The game stamps letters as a text engine. Most of the letters are now really blurry and faint, except for a few that are really bold.

TURTLE1019101

My game I have been working on was working fine. All of a sudden, when scratch 3.0 came along, the game was totally broken

this is the script for the play button which is broken
when this sprite clicked
hide
broadcast [ v]






scratch
please HHHHHHELP:(:(:(:(:(:(:(:(:(:(:(:(:(:(:(

mudlark0000

No error message has been displayed on any project and This is all on chrome on iMac.

here is a list of my projects that have broken;

https://scratch.mit.edu/projects/174167603/

all code has dissapeared (it was a PTE) and nothing runs.

https://scratch.mit.edu/projects/274240389/

the code of the pte (from above project) has disappeared

https://scratch.mit.edu/projects/155969604/ and https://scratch.mit.edu/projects/142340130/

platformer script is missing as is the grappling hook but both still function. and for the second link some of the hitboxes are off (this also occurs in an unshared project.)

i hope this helps


RUI79

estuve trabajando en un proyecto pero ya de repente no pude entrar y me marca este error, soy nuevo en scratch
[Your text to link here…

Ultra_Sonic75

dietbacon wrote:

Hi all!

Is one or more of your projects not loading, returning an error, or just seems to behave a lot differently than it did in Scratch 2.0? If so, please respond to this post with the following template filled out with as much detail as possible:

Project URL(s):

Error message displayed (if any):

Browser version & Operating System this happens in:

What browser extensions do you have installed (if any)?:

Description / other details of the behavior you see:


Note: This is not meant to collect reports about projects failing to load due to server issues, as these are temporary issues which are typically caused by heavy use of Scratch.
Okay, so I only have Scratch enhancement extensions (Like Furball)
And I use the latest version of Google Chrome (Which is apparently the BEST CHOICE for Scratch 3)
And I have Windows 10.
So when the project tries to load, it looks like it's loading, but it never does. Just to test it, I left my PC on for an entire day, and it still didn't load. It happens with EVERY. SINGLE. PROJECT.

TheCodingMonster

Hello there! I have been having problems with one of my projects that i have been working on. I had been editing it in scratch version 2.0 and then of course scratch updated to 3.0.

I am on the latest version of Google Chrome and i use a Windows 10 PC.

I entered my project and had a look around as I haven't seen 3.0 yet. I began testing my project until i came across an issue. I had programmed the character to die if it touched red or grey, and the 1st level was just floor, but as i moved the character forward it kept dying. I hadn't set the floor to be red or grey but it still happened. I never had this problem with 2.0 and it has messed up my project. I don't know how to fix it.

If you can help that would be great!

Thanks!

moosasa

my programming dissapeared on my latest project. hOWEVER, THE GAME STILL WORKS

here's the link: https://scratch.mit.edu/projects/268867299/
My browser: Chrome
Extentions: a lot (Grammarly, screencastify, ad block, stayfocusd, boxheads,)



QuantumShard

So basicly a lot of people are going to have this error on there projects because the Undertale Simple Battle Creator has 70000 remixes. Everything in it works fine, exept for the sprite g.soul. This sprite is supposed to be what you control, and you can no longer move it. The only thing I could thik of is that 3.0 broke the custom blocks (this project has no hacked blocks Im pretty sure). This has made entire accounts like mine filled with unsuable projects.


The projet that this glitch first occured in: https://scratch.mit.edu/projects/119165826/
My browser / operating system: ChromeOS 11021.81.0, Chrome 70.0.3538.110, No Flash version detected (We have shockwave on these computere
No error messages.


Please fix this,
QuantumShard